本文章所有命令均在Proxmox-VE进行实测并列出了各种BUG,本文涉及的命令均为Linux KVM QEMU虚拟化通用命令,如命令有不兼容十分拜托您务必联系我修正文章!十分感谢!
以下命令中10.0.1.$i是因为本次批量部署节点均在10.0.1.0/24段,需自行修改为你节点所在网段,如192.168.100.$i
批量创建网卡适用于如本次部署一样的情况,如外网网线统一连接到enp6s0网口,然后桥接到vmbr1给虚拟机连接使用,请根据你的情况自行修改
批量加集群
更新:利用expect实现初次连接自动登陆或自动上传ssh key
1 | 初次连接自动登陆 |
1 | 从创建集群的主节点批量远程自动加集群 |
批量从模板恢复虚拟机,比克隆更骚的办法
vzdump生成的备份恢复时是根据名称匹配的,如果修改了命名会导致恢复失败,使用qmrestore恢复前一定要还原名称
如需临时命名以便区分备份文件,强烈建议添加前缀,不要修改原本的文件名!
-storage指向的目标存储不能为共享!否则会出现cfs无法锁定报错(local在集群中错误的设置为了共享发现的)
1 | 加了集群之后可以免密了!!! |
加错集群处理办法
主节点批量移除失效节点
1 | 删除[104到124]的所有节点,yge是因为我的节点名前缀为yge,可以根据你的hostname来 |
在主节点删除后子节点会残留集群信息无法加入,需清除残留信息
1 | 一条龙清理 |
因ssh -t无法处理!,所以迫不得已使用脚本执行
1 | !/bin/bash |
基于免密后批量配置crontab
1 | for i in {101..103};do ssh [email protected].$i -t "crontab -e";done |